Proxy issues

Topics: Developer Forum
Aug 17, 2006 at 9:01 AM
Just a quick post to say love the plugin.

Unfortunately the proxy doesn't work for me, but hey, thats life.

You can set the FlickrNet proxy from the Writer Proxy by setting

flickr.Proxy = (System.Net.WebProxy)PluginHttpRequest.GetWriterProxy();
Aug 17, 2006 at 10:39 AM
Oh, and a workaround to get it working is to add the following to your WindowsLiveWriter.exe.config file at the top:

<configuration>
<configSections>
<section name="flickrNet" type="FlickrNet.FlickrConfigurationManager,FlickrNet"/>
</configSections>
<flickrNet>
<proxy ipaddress="proxyserver" port="8080" />
</flickrNet>
...
</configuration>
Coordinator
Aug 17, 2006 at 5:01 PM
We are doing this in the code if the proxy settings are there from writer...interesting that it isn't working...is there anything in the writer log file that may help?
Aug 18, 2006 at 2:45 PM
not sure - I'll double check.
Aug 22, 2006 at 2:18 PM
OK, it works now for some reason. Very strange.

I did however get an error (null reference) when I click "Insert Image" before the current images have finished downloading.
Aug 22, 2006 at 2:28 PM
Error report:

System.NullReferenceException: Object reference not set to an instance of an object.
at System.Windows.Forms.ToolStripControlHost.SetVisibleCore(Boolean visible)
at System.Windows.Forms.ToolStripItem.set_Visible(Boolean value)
at SmilingGoat.WindowsLiveWriter.Flickr.InsertFlickrImageForm.imageProcessor_ProgressChanged(Object sender, ProgressChangedEventArgs e)
at System.ComponentModel.BackgroundWorker.OnProgressChanged(ProgressChangedEventArgs e)
at System.ComponentModel.BackgroundWorker.ProgressReporter(Object arg)
Coordinator
Sep 8, 2006 at 6:15 AM
This discussion has been copied to Work Item 3005. You may wish to continue further discussion there.